Jira Cloud - Changed UI of the Create Screen in Jira leads to incorrect display of custom fields

I was in the process of creating a new issue in Jira Cloud when I noticed that the creation display seemed to be broken. I see the UI of the Awesome Custom Fields app I installed right in the Create screen, and I feel like I can’t configure there correctly, but that something is broken.
Can you guys help here? Is there an explanation for this change?
I attached an image to make clear, what I am talking about. I mean it kind of works, but at least it looks broken to me.

Would love to hear from you!

Hey there!
This is probably a question that currently affects every customer, which is why I would like to answer it quickly.
Atlassian indeed announced that they have released an update for Forge (the platform on which we develop our app), including an attractive feature. Namely, the so-called inline editing of custom fields in the Create mask of Jira.

This is the part of the changelog that is relevant for us:

We are already working on an improved rendering for this case and hope to release an update in the next few days, which will end up making our Custom Field Types even faster and easier to use.

Be excited for the next update and stay tuned!

1 Like

I’m more than happy and proud to announce that just a few moments ago, we released a new version that fixes the issues we encountered yesterday due to the forge update by Atlassian.

In addition to that, we’ve fixed and improved some related UI issues. This leads to excellent usability when creating new issues.